Repozytoria dla starych wersji Ubuntu

Wersje Ubuntu w końcu się przestarzają, ale nie wszyscy chcą lub nie wszyscy mogą go zaktualizować. W pewnym momencie odczuwamy spore braki – brak repozytoriów z pakietami. Nie możemy nic z nich ściągnąć, a przy wpisywaniu komendy apt-get update zostajemy zawaleni dużą ilością komunikatów 404 Not Found.

Co zrobić, żeby repozytoria w starych wersjach ubuntu znów działały?

Musimy edytować plik /etc/apt/sources.list
nano /etc/apt/sources.list
lub jeśli nie posiadamy Nano, bo nie możemy go ściągnąć (no właśnie…) to użyjemy Vi (którego nie bardzo lubię, ale w takich sytuacjach jestem zmuszony używać)
vi /etc/apt/sources.list

Plik całkowicie czyścimy. To co tam jest, już się nam nie przyda. Teraz wklejamy coś takiego:
deb http://old-releases.ubuntu.com/ubuntu/ natty main restricted
deb http://old-releases.ubuntu.com/ubuntu/ natty-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ natty universe
deb http://old-releases.ubuntu.com/ubuntu/ natty-updates universe
deb http://old-releases.ubuntu.com/ubuntu/ natty multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-updates multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-security main restricted
deb http://old-releases.ubuntu.com/ubuntu/ natty-security universe
deb http://old-releases.ubuntu.com/ubuntu/ natty-security multiverse

Zaraz zaraz… Wszędzie widzę Natty, a może moja wersja Ubuntu to Gutsy? W takim razie zamieniamy wszystkie natty, na gutsy:

deb http://old-releases.ubuntu.com/ubuntu/ gutsy main restricted
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ gutsy universe
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates universe
deb http://old-releases.ubuntu.com/ubuntu/ gutsy multiverse
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security main restricted
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security universe
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security multiverse

Tak więc zmieniamy wersję naszego Ubuntu w tym, co podałem powyżej i wklejamy do edytora nano lub Vi.

Wiem dobrze, że edytowanie plików przez terminal dla niektórych to czarna magia, więc wytłumaczę jeszcze, jak zapisać taki plik.

Nano

Wciskamy „Ctrl + O” (gdzie O to litera, a nie cyfra!). Po tym wciskamy „Ctrl + X”.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

CommentLuv badge